3rd July 2019

Extended Maintenance - All realms, scheduled 2 weeks ago

We have to perform changes and maintenance on our backend infrastructure which means all realms will be unavailable for around 2 hours.

During this period, all of our services including our website will be down.

Update 1 - 12:28 ST

Maintenance is well underway, however zipping up and transfering a rather large logfile (around 130GB) is taking a bit longer than expected.

Update 2 - 12:50 ST

Maintenance is extended by at least 1 hour.

We apologize for the inconvenience.

Update 3 - 13:59 ST

The only remaining activity is importing the Northdale Character database which is 2/3 complete. Not too long remaining.

Update 3 - 14:18 ST

And we're done. Have fun.

Please notify us immediately if anything is out of the ordinary.

Thank you.